Project

General

Profile

Actions

Bug #103101

closed

Out of range value for column 'recuid'

Added by Markus Klein 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Backend API
Target version:
-
Start date:
2024-02-12
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Core: Exception handler (WEB): Uncaught TYPO3 Exception: An exception occurred while executing 'INSERT INTO `sys_log` (`userid`, `type`, `channel`, `level`, `action`, `error`, `details_nr`, `details`, `log_data`, `tablename`, `recuid`, `IP`, `tstamp`, `event_pid`, `NEWid`, `workspace`) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)' with params [7, 1, "content", "info", 4, 1, 14, "Attempt to move record \"\" () without having permissions to do so. []", "a:3:{i:0;s:10:\"[No title]\";i:1;s:8:\"pages:-1\";i:2;s:35:\"ERROR: Record could not be fetched.\";}", "pages", -1, "91.112.x.x", 1706278593, 0, "", 0]: Out of range value for column 'recuid' at row 1 | Doctrine\DBAL\Exception\DriverException thrown in file vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/AbstractMySQLDriver.php in line 128.

Obviously the page uid `-1` is not allowed.

Actions #1

Updated by Markus Klein 2 months ago

The causing line seems to be \TYPO3\CMS\Core\DataHandling\DataHandler::moveRecord:

        if (!$mayEditAccess) {
            $this->log($table, $uid, SystemLogDatabaseAction::MOVE, 0, SystemLogErrorClassification::USER_ERROR, 'Attempt to move record "{title}" ({table}:{uid}) without having permissions to do so [{reason}]', 14, ['title' => $propArr['header'], 'table' => $table, 'uid' => $uid, 'reason' => $this->BE_USER->errorMsg], $propArr['event_pid']);
            return;
        }
Actions #2

Updated by Gerrit Code Review 2 months ago

  • Status changed from New to Under Review

Patch set 1 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/82897

Actions #3

Updated by Gerrit Code Review about 1 month ago

Patch set 2 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/82897

Actions #4

Updated by Gerrit Code Review about 1 month ago

Patch set 3 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/82897

Actions #5

Updated by Gerrit Code Review about 1 month ago

Patch set 1 for branch 12.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/83336

Actions #6

Updated by Gerrit Code Review about 1 month ago

Patch set 1 for branch 11.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/83337

Actions #7

Updated by Markus Klein about 1 month ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions

Also available in: Atom PDF