Project

General

Profile

Actions

Bug #103134

closed

backend:user:create Symfony Command CLI does not recognize short options

Added by Garvin Hicking about 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
CLI
Target version:
Start date:
2024-02-16
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
12
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Tested with TYPO3v12 and main (v13), I cannot specify short option commands to the CLI:

./vendor/bin/typo3 backend:user:create -u superadmin -password=MyPassWord-2 -a -m

This instead works:

./vendor/bin/typo3 backend:user:create --username=superadmin --password=MyPassWord-2 --admin --maintainer

The reason is that the typo3/sysext/backend/Classes/Command/CreateBackendUserCommand.php file uses $input->hasParameterOption('--' . $option) which only checks for the long option and not the short option; the method description specifically mentions that short codes are not avaluated.

Actions #1

Updated by Gerrit Code Review about 2 months ago

  • Status changed from New to Under Review

Patch set 1 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/83018

Actions #2

Updated by Gerrit Code Review about 2 months ago

Patch set 2 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/83018

Actions #3

Updated by Gerrit Code Review about 1 month ago

Patch set 3 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/83018

Actions #4

Updated by Gerrit Code Review about 1 month ago

Patch set 1 for branch 12.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/83376

Actions #5

Updated by Garvin Hicking about 1 month ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions

Also available in: Atom PDF