Project

General

Profile

Actions

Bug #103169

closed

Empty Flexform values

Added by Mordamir 2 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
felogin
Target version:
-
Start date:
2024-02-21
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
8.1
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Since some newer version typo3 stores also empty values for flexforms (felogin in this case). Dont know since which version, we normaly never update the felogin plugin settings.
This means that now the value for example settings.pages is empty. This wouldnt be a problem if this empty value would not overwrite the value set per typoscript.
I think at some point typo3 changed the order of how the values in the settings-array of a plugin are evaluated. Or the handling of empty values changed.
The question now is: How can i configure a plugin setting per typoscript, if this is overwriten by an empty flexform value. By "empty" i mean there is a configuration key, but no value associated.

I sorted this report to category "felogin", because i havent found a "flexform" category.

Actions #1

Updated by Torben Hansen about 2 months ago

  • Status changed from New to Closed

The old legacy plugin of ext:felogin did not show this behavior with empty flexform values, but the extbase version (introduced in TYPO3 9.5) of the plugin does. This general problem with Extbase plugins and FlexForm has been addressed in TYPO3 12.4 and a general solution for the problem has been introduced with #99976

An official backport of the new feature is not available and will most likely not be provided, since TYPO3 11.5 is in priority bugfix state. There is however a user contribution available for TYPO3 11.5 (see comment in #92363), so if you can not update your website to TYPO3 12.4, I suggest you use composer patch your TYPO3 11.5 website with the user contribution patch available in #92363

Since the described issue has been resolved in TYPO3 12.4, I close this issue now.

Actions

Also available in: Atom PDF