Project

General

Profile

Actions

Bug #103461

closed

Can't switch off Admin Edit Lock of pages in Access Module of v11

Added by Christian Ludwig 4 months ago. Updated 6 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend API
Target version:
Start date:
2024-03-21
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
11
PHP Version:
8.2
Tags:
Access Admin
Complexity:
easy
Is Regression:
Sprint Focus:

Description

In TYPO3 v11 it is not possible to switch off the "Admin-only" edit lock (DB field page.editlock) in the Access Module.

Doctrine throws an error:
Incorrect integer value: '' for column 'editlock' at row 1

Please change line 201 in sysext/beuser/Classes/Controller/PermissionController.php from

            case 'toggle_edit_lock':
                // Initialize requested lock state
                $editLockState = !$conf['editLockState'];

to

            case 'toggle_edit_lock':
                // Initialize requested lock state
                $editLockState = $conf['editLockState'] ? 0 : 1;

In TYPO3 v12 I can't reproduce this behaviour.


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Task #103462: Admin-only edit lock can be disabled again in v11.5Closed2024-03-21

Actions
Actions #2

Updated by Christian Ludwig 4 months ago

  • Subject changed from Can't switch of Admin Edit Lock of pages in Access Module of v11 to Can't switch off Admin Edit Lock of pages in Access Module of v11
Actions #3

Updated by Christian Ludwig 4 months ago

  • Related to Task #103462: Admin-only edit lock can be disabled again in v11.5 added
Actions #4

Updated by Gerrit Code Review 4 months ago

  • Status changed from New to Under Review

Patch set 2 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/83564

Actions #5

Updated by Gerrit Code Review 4 months ago

Patch set 3 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/83564

Actions #6

Updated by Gerrit Code Review 4 months ago

Patch set 1 for branch 12.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/83541

Actions #7

Updated by Gerrit Code Review 4 months ago

Patch set 1 for branch 11.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/83542

Actions #8

Updated by Gerrit Code Review 4 months ago

Patch set 2 for branch 11.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/83542

Actions #9

Updated by Anonymous 4 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #10

Updated by Benni Mack 6 days ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF