Project

General

Profile

Actions

Task #103628

closed

Avoid deprecation notice in SystemInformationToolbarItem->addSystemInformation()

Added by Kevin Appelt 3 months ago. Updated 6 days ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2024-04-14
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
13
PHP Version:
Tags:
Complexity:
no-brainer
Sprint Focus:

Description

TYPO3 Deprecation Notice: Using a string of the non-native enumeration TYPO3\CMS\Backend\Toolbar\Enumeration\InformationStatus for $status in SystemInformationToolbarItem->addSystemInformation() has been deprecated and will stop working in TYPO3 v14.0. Use the native TYPO3\CMS\Backend\Toolbar\InformationStatus instead.

This is caused by:
https://github.com/TYPO3/typo3/blob/main/typo3/sysext/scheduler/Classes/SystemInformation/ToolbarItemProvider.php#L84
So if the scheduler was NOT started manually (but f.e. by a cronjob) the value passed for $severity is an empty string.

We can mitigate the issue by setting $severity by default to InformationStatus::NOTICE which is the default for SystemInformationToolbarItem->addSystemInformation()

This only effects TYPO3 v13/main.

Actions #1

Updated by Gerrit Code Review 3 months ago

  • Status changed from New to Under Review

Patch set 1 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/83782

Actions #2

Updated by Kevin Appelt 3 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #3

Updated by Benni Mack 6 days ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF