Project

General

Profile

Actions

Bug #103957

closed

form-extension: multiple recipients in email finisher does not work

Added by wini2 no-lastname-given about 2 months ago. Updated 22 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2024-05-30
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

As mentioned in https://docs.typo3.org/c/typo3/cms-core/main/en-us/Changelog/10.0/Feature-80420-AllowMultipleRecipientsInEmailFinisher.html and https://docs.typo3.org/c/typo3/cms-form/12.4/en-us/E/Finishers/Index.html it should be possible to send mails via form-extension but only the first gets an email

renderingOptions:
  submitButtonLabel: Absenden
identifier: simplecontactform
label: Simplecontactform
type: Form
prototypeName: standard
finishers:
  -
    options:
      subject: 'Your message: {subject}'
      recipients:
        first@example.org: First Recipient
        second@example.org: SecondRecipient
      senderAddress: '{email}'
      senderName: '{name}'
      attachUploads: true
      translation:
        language: ''
      useFluidEmail: true
      title: 'Confirmation of your message'
      addHtmlPart: true
    identifier: EmailToReceiver
renderables:
  -
    renderingOptions:
      previousButtonLabel: 'Vorherige Seite'
      nextButtonLabel: 'Nächster Schritt'
    identifier: page-1
    label: 'Contact Form'
    type: Page
    renderables:
      -
        defaultValue: ''
        identifier: name
        label: Name
        type: Text
        properties:
          fluidAdditionalAttributes:
            placeholder: Name
      -
        defaultValue: ''
        identifier: subject
        label: Subject
        type: Text
        properties:
          fluidAdditionalAttributes:
            placeholder: Subject
      -
        defaultValue: ''
        identifier: email
        label: Email
        type: Text
        properties:
          fluidAdditionalAttributes:
            placeholder: 'Email address'
        validators:
          -
            identifier: EmailAddress
      -
        defaultValue: ''
        identifier: message
        label: Message
        type: Textarea
        properties:
          fluidAdditionalAttributes:
            placeholder: ''
  -
    renderingOptions:
      previousButtonLabel: 'Vorherige Seite'
      nextButtonLabel: 'Nächster Schritt'
    identifier: summarypage
    label: 'Summary page'
    type: SummaryPage
Actions #1

Updated by wini2 no-lastname-given about 2 months ago

  • Description updated (diff)
Actions #2

Updated by Georg Ringer about 1 month ago

  • Status changed from New to Needs Feedback

couldn't reproduce that in latest version (v13), can you please test this in at v11 or v12 as well? v10 is not supported anymore

Actions #3

Updated by Georg Ringer 22 days ago

  • Status changed from Needs Feedback to Closed

closing because lack of feedback and couldn't be reproduced anymore

Actions

Also available in: Atom PDF