Bug #14479

Sorting and display of fields in ext_conf_template.txt

Added by Wolfgang Klinger almost 15 years ago. Updated over 13 years ago.

Status:
Closed
Priority:
Should have
Category:
Backend API
Target version:
-
Start date:
2005-01-03
Due date:
% Done:

0%

TYPO3 Version:
3.7.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The configuration fields defined in ext_conf_template.txt are displayed in reverse order in the extension manager.

(issue imported from #M660)

T3X_gremlin0660demo-0_0_0-z-200510191812.t3x (3.22 KB) Administrator Admin, 2005-10-19 18:28

gremlin0660_typo3_370.png View (38.3 KB) Administrator Admin, 2005-10-19 18:28

Associated revisions

Revision e956ce90 (diff)
Added by Xavier Perseguers over 9 years ago

Fixed bug #14479: Speed up Oracle layer by not defaulting to dbms_lob.instr for LIKE query (thanks to Michiel Roos)

git-svn-id: https://svn.typo3.org/TYPO3v4/Extensions/dbal/trunk@33885 735d13b6-9817-0410-8766-e36946ffe9aa

Revision 0c80ad4b (diff)
Added by Xavier Perseguers over 9 years ago

Backported changeset 33885 from trunk: Fixed bug #14479

git-svn-id: https://svn.typo3.org/TYPO3v4/Extensions/dbal/branches/DBAL_1-1@33886 735d13b6-9817-0410-8766-e36946ffe9aa

History

#1 Updated by Rainer Kuhn about 14 years ago

The configuration fields defined in ext_conf_template.txt are not displayed in reverse order, they seem to be displayed arbitrarily. It's nearly impossible to get a pre-defined display order - sometimes that's very annoying (especially for more complex configuration templates).
I really hope this Gremlin will be zapped... :)
Cheers, Rainer

#2 Updated by Rainer Kuhn about 14 years ago

One more annotation: Some kind of numbering system within the categories, i.e. the same as used in ext_typoscript_constants.txt, would be very helpful

#3 Updated by Sebastian Kurfuerst about 14 years ago

could you please give me an example (i.e. an extension where the ordering is messed up)? thanks, sebastian

#4 Updated by Rainer Kuhn about 14 years ago

I have experienced this problem with TYPO3 versions below 3.8.0 and did not expect it to be solved since this bugtracker issue was still "new". For demonstation issues I've created a small extension attached here: T3X_gremlin0660demo-0_0_0-z-200510191812.t3x

Tested again on a 3.7.0 installation again all entries have been messed up (see attached screenshot gremlin0660_typo3_370.png)

As I've found right now, to my surprise the problem seems to be fixed with TYPO3 3.8.0 (tested on 2 different installations). So if this is correct, there's nothing do for me... :) Maybe you could try my demo extension with another 3.8.0 installation.

#5 Updated by Sebastian Kurfuerst about 14 years ago

everything works - I like these bugs most ;)
Greets, Sebastian

Also available in: Atom PDF