Bug #15071

Clean up the new page content items list

Added by Matthew about 15 years ago. Updated over 14 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2005-10-17
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
3.8.0
PHP Version:
4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Current menu items:
Regular text element
Text with image below
Text with image to the right

These should be cleaned, remove one of the text/image items and just call it 'Text w/image"

Then Text should be renamed Text w/header - because that is what it actually gives you.

New menu items:
Text w/header
Text w/image

:-)

(issue imported from #M1628)


Related issues

Related to TYPO3 Core - Feature #15150: Get list of content elements for "new content" wizard from TCAClosedErnesto Baschny2005-10-24

Actions
#1

Updated by Kirill Klimov about 15 years ago

Also suggest to synchronize list of elements at the new page element wizard and at the page content.
Because for now some are present only via content type (insert records) - so when you want to create new record of type "insert records" you should chose anything at wizard and then change type...

#2

Updated by Ernesto Baschny about 15 years ago

A "Text w/ image" also can have a header. So I would just call it:

"Text"
"Text with image"

#3

Updated by Ernesto Baschny about 15 years ago

Maybe we could enhance this wizard and have the information about the CTypes come directly from the TCA. So I could add other CTypes to the wizard. Of course this means adding more parameters to TCA and have them being evaluated by the cms/layout/db_new_content_el.php wizard.

#4

Updated by Michael Stucki about 15 years ago

Ernesto, I like that idea. However I think it should be implemented separately from this issue. Can you please move it to a new bug record?

#5

Updated by Ernesto Baschny about 15 years ago

@Michael:

Done! New splitted "feature request" is http://bugs.typo3.org/view.php?id=1723

#6

Updated by Michael Stucki about 15 years ago

Thanks, Ernesto!

#7

Updated by Sacha Vorbeck about 15 years ago

keyword:usability

#8

Updated by Michael Stucki almost 15 years ago

Fixed in CVS

Also available in: Atom PDF