Bug #15188

EM doesn't check for dependancies on Extension update

Added by Ingmar Schlecht over 15 years ago. Updated over 14 years ago.

Status:
Closed
Priority:
Should have
Category:
Extension Manager
Target version:
-
Start date:
2005-11-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
3.8.0
PHP Version:
4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The EM doesn't check for dependancies when you upgrade an extension.

That causes the following error message when you update from an older version of tt_products to the latest: "TYPO3 Fatal Error: Extension key "fh_library" was NOT loaded! (t3lib_extMgm::extPath)".

(issue imported from #M1807)

#1

Updated by Franz Holzinger over 15 years ago

I think this is of high priority because the backend is not usable any more afterwards.

#2

Updated by Sebastian Kurfuerst over 15 years ago

Hi,
I head that you are right now working on the EM-
It would be great if you could have a look.
Thanks,
Sebastian

#3

Updated by Franz Holzinger about 15 years ago

It would be great if this could come into TYPO3 4.0 RC1.

#4

Updated by Karsten Dambekalns about 15 years ago

I'll send a patch RFC to the core list today, please have a look.

Also available in: Atom PDF