Bug #15672

problem with selecting random mirror in extension manager

Added by Peter Niederlag over 15 years ago. Updated almost 15 years ago.

Status:
Closed
Priority:
Should have
Category:
Extension Manager
Target version:
-
Start date:
2006-02-19
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.0
PHP Version:
4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Theres a bug in the function:

SC_mod_tools_em_index->getMirrorURL()

As long as one hasn#t set a prefered mirror the code is supposed to select a mirror on a random base from an array by using the function

$rand=array_rand$mirrors)

array_rand returns an Integer when called without the second argument therfor the line

$url = 'http://'.$mirrors[$rand0]['host'].$mirrors[$rand0]['path'];

does not wok as intended.

small attached patch fixes the problem.

(issue imported from #M2630)


Files

random-mirror-em.diff (835 Bytes) random-mirror-em.diff Administrator Admin, 2006-02-19 14:37

Related issues

Has duplicate TYPO3 Core - Bug #15665: EXT-Mgr: Update from TER fails with no meaningful ERROR, without setting the mirror first;ClosedKarsten Dambekalns2006-02-18

Actions
Has duplicate TYPO3 Core - Bug #15653: Error while fetching extension list - no extensions can be installed from TERClosedKarsten Dambekalns2006-02-17

Actions

No data to display

Also available in: Atom PDF