Bug #15792

adodb should be non-shy (or dbal should be shy)

Added by Michael Scharkow over 15 years ago. Updated almost 15 years ago.

Status:
Closed
Priority:
Should have
Category:
Database API (Doctrine DBAL)
Target version:
-
Start date:
2006-03-09
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Whenever a user tries to install dbal, a dependency error is thrown relating to adodb, but since adodb is shy, some users will not find it and thus won't be able to install it and then dbal.
For consistency, both extensions should either be shy or non-shy.

I guess automatic deps resolving will only come with 4.5, right?
(issue imported from #M2810)

#1

Updated by Karsten Dambekalns over 15 years ago

It probably should not be shy in this case, true.

But dependency handling resolves this right now, even if it still was shy. :)

#2

Updated by Karsten Dambekalns over 15 years ago

Fixed in CVS, is non-shy now.

Also available in: Atom PDF