Bug #15869

Selection of Template Records in a draft workspace doesn't filter start/endtime and hidden field correctly

Added by Kasper Skaarhoj almost 14 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2006-03-21
Due date:
% Done:

0%

TYPO3 Version:
4.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In t3lib_tstemplate.php the template records from the root line is collected by a series of SQL statements. Template Records are filtered with $this->whereClause which includes check for "enableFields" and "deleted", all initialize in the init() function.
Under preview in draft workspaces the correct behaviour would be to select all records and filter away those which are marked deleted, hidden in the workspace, start/endtime in workspace etc. This doesn't happen at the moment.
However, I don't consider the fix trivial because it must be made sure that any draft composition of template records is _NOT_cached (which could affect online site).

(issue imported from #M2946)

History

#1 Updated by Tolleiv Nietsch almost 8 years ago

  • Category deleted (Miscellaneous)
  • Status changed from New to Closed
  • Target version deleted (0)
  • PHP Version deleted (5)

Afaik not relevant anymore

#2 Updated by Michael Stucki about 6 years ago

  • Category set to Workspaces

#3 Updated by Michael Stucki about 6 years ago

  • Project changed from Workspaces & Versioning to TYPO3 Core
  • Category changed from Workspaces to Workspaces

Also available in: Atom PDF