Bug #16005

DAM install fails on typo3 with postgresbased DB

Added by old_pss7 almost 16 years ago. Updated over 15 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Database API (Doctrine DBAL)
Target version:
-
Start date:
2006-04-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

the extension manager brings up many sql errors ;-)

postgres 8.1, OIDs enabled

ERROR: Query could not be parsed: "SQL engine parse ERROR: Field type unknown in parseFieldDef()!: near "float unsigned NOT NULL default '0', height float "". Query: "CREATE TABLE tx_dam ( uid int(11) NOT NULL auto_increment, pid int(11) NOT NULL default '0', tstamp int(11) unsigned NOT NULL default '0', crdate int(11) unsigned NOT NULL default '0', cruser_id int(11) unsigned NOT NULL default '0', parent_id int(11) NOT NULL default '0', deleted tinyint(4) unsigned NOT NULL default '0', active tinyint(4) unsigned NOT NULL default '0', sorting int(10) unsigned NOT NULL default '0', hidden tinyint(4) unsigned NOT NULL default '0', starttime int(11) unsigned NOT NULL default '0', endtime int(11) unsigned NOT NULL default '0', fe_group int(11) NOT NULL default '0', sys_language_uid int(11) NOT NULL default '0', l18n_parent int(11) NOT NULL default '0', l18n_diffsource mediumblob NOT NULL, t3ver_oid int(11) NOT NULL default '0', t3ver_id int(11) NOT NULL default '0', t3ver_label varchar(30) NOT NULL default '', media_type tinyint(4) unsigned NOT NULL default '0', title tinytext NOT NULL, category int(11) NOT NULL default '0', index_type varchar(4) NOT NULL default '', file_mime_type varchar(45) NOT NULL default '', file_mime_subtype varchar(45) NOT NULL default '', file_type varchar(4) NOT NULL default '', file_type_version varchar(9) NOT NULL default '', file_name varchar(100) NOT NULL default '', file_path tinytext NOT NULL, file_size int(11) unsigned NOT NULL default '0', file_mtime int(11) unsigned NOT NULL default '0', file_inode int(11) NOT NULL default '0', file_ctime int(11) unsigned NOT NULL default '0', file_hash varchar(32) NOT NULL default '', file_status tinyint(4) unsigned NOT NULL default '0', file_orig_location varchar(255) NOT NULL default '', file_orig_loc_desc varchar(45) NOT NULL default '', file_creator varchar(45) NOT NULL default '', file_dl_name varchar(100) NOT NULL default '', file_usage int(11) unsigned NOT NULL default '0', meta text NOT NULL, ident varchar(45) NOT NULL default '', creator varchar(45) NOT NULL default '', keywords tinytext NOT NULL, description text NOT NULL, alt_text varchar(255) NOT NULL default '', caption text NOT NULL, abstract text NOT NULL, search_content text NOT NULL, language char(3) NOT NULL default '', pages int(4) unsigned NOT NULL default '0', publisher varchar(45) NOT NULL default '', copyright varchar(128) NOT NULL default '', instructions tinytext NOT NULL, date_cr int(11) unsigned NOT NULL default '0', date_mod int(11) unsigned NOT NULL default '0', loc_desc varchar(45) NOT NULL default '', loc_country char(3) NOT NULL default '', loc_city varchar(45) NOT NULL default '', hres int(11) unsigned NOT NULL default '0', vres int(11) unsigned NOT NULL default '0', hpixels int(11) unsigned NOT NULL default '0', vpixels int(11) unsigned NOT NULL default '0', color_space varchar(4) NOT NULL default '', width float unsigned NOT NULL default '0', height float unsigned NOT NULL default '0', height_unit char(3) NOT NULL default '', PRIMARY KEY (uid), KEY parent (pid), KEY media_type (media_type), KEY t3ver_oid (t3ver_oid) );"
(issue imported from #M3177)


Related issues

Is duplicate of TYPO3 Core - Bug #15900: float is not a db-compatible datatypeClosedKarsten Dambekalns2006-03-26

Actions

No data to display

Also available in: Atom PDF