Bug #16091

Try to upload extension: SOAP-ENV:Client: Bad Request

Added by Andre Obereigner over 13 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extension Manager
Target version:
-
Start date:
2006-04-26
Due date:
% Done:

0%

TYPO3 Version:
4.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When I try to upload my new extension to the repository, the error message "SOAP-ENV:Client: Bad Request" always occurs. The extension name is without underscores "_". I also tried to use different upload comments. But there is always the same error.

I am using Typo3 4.0.

Does somebody have an idea?

(issue imported from #M3356)

History

#1 Updated by Schopfer Olivier over 13 years ago

Same problem for me with a new extension

#2 Updated by Andre Obereigner over 13 years ago

Someone told me that soap support might not be enabled on Windows. So I had a look and it was true. After adding extension=php_soap.dll in php.ini, the upload of my extension worked without any problems.

#3 Updated by Schopfer Olivier over 13 years ago

Does this mean that the soap extension has to be compiled with php on the Typo3 server? I'm operating a Linux server, and did not include the soap extensions so far. It didn't seem to be required with Typo3 3.8.1.

http://ch2.php.net/manual/en/ref.soap.php

Or any other configuration?

#4 Updated by dan frost almost 13 years ago

I had this issue on linux and fixed this by installing SOAP into PHP. PHP version was 5.x.

#5 Updated by Robert Lemke over 12 years ago

The error only occurs if the NuSOAP implementation is used - if the PHP SOAP implementation is active, uploads work fine.

#6 Updated by Robert Lemke over 12 years ago

Karsten's patch in 4.1beta2 works for me. Today I tested an extension upload with the PHP5 SOAP extension enabled. It worked fine but I got a little error:

Warning: unserialize() expects parameter 1 to be string, array given in typo3/mod/tools/em/class.em_terconnection.php on line 278

Karsten?

#7 Updated by Christian Kuhn almost 8 years ago

  • Status changed from New to Closed
  • Target version deleted (0)
  • PHP Version deleted (4)

Closed: Nusoap is not supported in younger TYPO3 versions anymore.

Also available in: Atom PDF