Bug #16721

Update Wizard wont overwrite compat_version mode, in case two lines given;

Added by Georg K├╝hnberger almost 13 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Should have
Category:
Install Tool
Target version:
-
Start date:
2006-11-17
Due date:
% Done:

0%

TYPO3 Version:
4.0
PHP Version:
4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

in localconf.php I had (for whatever reason) 2 entries in the following order:
localconf.php
-----------------
$TYPO3_CONF_VARS['SYS']['compat_version'] = '4.0';
$TYPO3_CONF_VARS['SYS']['compat_version'] = '3.8';

Now running through the Installtool like:
InstallTool >>> 3: Update Wizard >>> 4.0 >>> accept all
confirmed that the needed changes would have been made;

however localconf.php still showed - in order:
-----------------
$TYPO3_CONF_VARS['SYS']['compat_version'] = '4.0';
$TYPO3_CONF_VARS['SYS']['compat_version'] = '3.8';

thus the instance was running 3.8;

PS: guess the second line was added manually at some point of time;
PPS: fix was manually deleting the 3.8 line;

(issue imported from #M4524)


Related issues

Duplicates TYPO3 Core - Bug #19845: Duplicated values in localconf.php (typo3conf) - compat_version Closed 2009-01-17

History

#1 Updated by Christian Kuhn over 9 years ago

This is probably a duplicate of #19845 and solved.

#2 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF