Bug #16766

IRRE relation to the same table shows new records twice

Added by Ingmar Schlecht over 14 years ago. Updated over 14 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2006-12-07
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.1beta1
PHP Version:
4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When making an IRRE inline relation to the same table as the parent table, tceforms shows the sub-record twice after saving [once (correctly) inside the parent record, and once underneath the parent record].

This has to do with alt_doc.php showing forms for all new items automatically if the tablename was in the $this->editconf array beforehand already (which is the case here, because the parent and the child table are the same).

cheers
Ingmar

(issue imported from #M4616)


Files

0004616.patch (2.78 KB) 0004616.patch Administrator Admin, 2006-12-07 22:35
#1

Updated by Oliver Hader over 14 years ago

In which general case does it happen, that more than one record is created on the same table? If this doen't occur otherwise, we could just take the first record which is in fact the parent record.

#2

Updated by Oliver Hader over 14 years ago

The easiest way would have been to just take the first record as mentioned in my last note. But I couldn't make out, what could come in conflict than or in other words: Why exactly has alt_doc.php this check?

So, I integrated a new variable $newRelatedIDs in TCEmain, that stores related child records. These records are not used for redirecting to.

See the attached patch.

#3

Updated by Ingmar Schlecht over 14 years ago

This is fixed in the beta2-patch, right?

#4

Updated by Oliver Hader over 14 years ago

Correct.

#5

Updated by Oliver Hader over 14 years ago

Commited to svn trunk by Ingmar.

Also available in: Atom PDF