Bug #16865

t3lib_div - PATH_typo3 problem for localizations

Added by Oliver Hader almost 13 years ago. Updated over 12 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Communication
Target version:
-
Start date:
2007-01-18
Due date:
% Done:

0%

TYPO3 Version:
4.1
PHP Version:
5
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I cannot exactly explain what was going on - it's strange...

t3lib_div has some functions to load locallang-files. If such a file has never been created/cached, it's going to be newly created. And this one uses the function t3lib_div::llXmlAutoFileName(...).

But: llXmlAutoFileName has some parts with "PATH_typo3" in it, and this definition isn't set in frontend at all.

The result: e.g. the german translation of indexed_search couldn't be fetched from typo3conf/l10n/de/indexed_search because of matching errors depending on a missing "PATH_typo3" definition.

The strange thing: If have TYPO3 sites, running 4.1beta2 and 4.0.4, where this doesn't occur - possibly there are extensions setting the PATH_typo3 or whatever...

(issue imported from #M4803)

0004803.patch View (1.19 KB) Administrator Admin, 2007-01-18 10:24


Related issues

Related to TYPO3 Core - Bug #16740: FE PATH_typo3 problem | Typo3 4.1b 1a Closed 2006-11-26

History

#1 Updated by Oliver Hader almost 13 years ago

According to bug 0004562, define the PATH_typo3 isn't a good idea.
The attached patch 0004803.patch replaces "PATH_typo3" by "PATH_site.TYPO3_mainDir".

#3 Updated by Oliver Hader almost 13 years ago

Masi provided a patch for that on defining the constant PATH_typo3. Thanks Masi!
It was commited to svn trunk (see http://svn.t3.digitaldistrict.de/cgi-bin/trac.cgi/changeset/6441).

Also available in: Atom PDF