Bug #16922

Error when installing sr_feuser_register

Added by R Wirschun over 12 years ago. Updated about 11 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2007-01-30
Due date:
% Done:

0%

TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Warning: Invalid argument supplied for foreach() in
/www/htdocs/w007ea46/freestyle/t3lib/class.t3lib_install.php on line 392

Typo3 V4.0.4

Details:

General information:
Title: Frontend User Registration
Description: A front end user self-registration variant of Kasper
Skårhøj's Front End User Admin extension.
Author: Stanislas Rolland, Franz Holzinger <>,
Freelancer
Version: 2.5.5
Category: Frontend Plugins
State: Stable
Shy?
Internal?
Depends on:
Conflicts with:
Suggests:
Priority:
Clear cache?
Includes modules:
Lock Type?
Modifies tables: fe_users

Installation status:
Type of install: Local - Local extensions (typo3conf/ext/) - Local for
this TYPO3 installation only (Dynamic).
Double installs?
Root files: ChangeLog
contributors.txt
ext_conf_template.txt
ext_emconf.php
ext_icon.gif
ext_localconf.php
ext_tables.php
ext_tables.sql
locallang.php
locallang.xml
locallang_db.php
locallang_db.xml
tca.php
Database requirements: Tables:
fe_groups_language_overlay

Additional fields:
fe_users: static_info_country, zone, language, gender, first_name,
last_name, name, status, country, zip, email, telephone, fax,
date_of_birth, comments, by_invitation, module_sys_dmail_html
Database status:
Flags: loadTCA
TCA
Plugin
Plugin/ST43
Config template? Yes
TypoScript files:
Language files: locallang.php
locallang_db.php
pi1/locallang.php
Upload folder: uploads/tx_srfeuserregister/
Create directories:
Module names:
Class names: tx_srfeuserregister_pi1
tx_srfeuserregister_pi1_adodb_time
tx_srfeuserregister_pi1_urlvalidator
tx_srfeuserregister_hooksHandler

Code warnings:
(developer-relevant)
Naming annoyances:
(developer-relevant)
fields
static_info_country static_info_country
zone zone
language language
gender gender
first_name first_name
last_name last_name
name name
status status
country country
zip zip
email email
telephone telephone
fax fax
date_of_birth date_of_birth
comments comments
by_invitation by_invitation
module_sys_dmail_html module_sys_dmail_html
tables
fe_groups_language_overlay fe_groups_language_overlay

Files changed?
(issue imported from #M4888)

History

#1 Updated by Daniel Mueller over 12 years ago

I have the same problem. This also happens when you go into details or when you try to download it via the disk-icon (extension manager). This does not seem to be an issue with typo3 v 4.0.2

I am not sure if this helps: I made my own extension with the kickstarter to extend sr_feuserregister by 3 fields. The problems described also appear with this extension.

#2 Updated by R Wirschun over 12 years ago

You can correct this problem when you make the following entries in the
class.t3lib_install.php on line 392
if (is_array($cfg['keys'])) {

and in Line 406
}

#3 Updated by Frank Loizzi over 12 years ago

The same happens with Typo3 4.1 RC2 and sr_feuser_register 2.5.5. As the error occured and still was displayed on the extension import page, I applied the source modification R. Wirschun mentioned. After that I pressed again the update button on the bottom and all went fine. A database check from the BE and a database compare via install tool showed no errors.

#4 Updated by Franz Holzinger over 12 years ago

What is the code around the line in class.t3lib_install.php on line 392 where this error occurs?

#5 Updated by Oliver Hader about 12 years ago

In the mentioned line there is the SQL parser that checks if e.g. ext_tables.sql is correct or which fields/tables are missing in the database. I could not reproduce on installing tx_feuserregister version 2.5.6.

@Franz: Please tell what changed between 2.5.5 and 2.5.6. Unfortunatelly I could not use SVN, because the tags were used for further development and I could not determine which revision was which TER version.

@reporter: Is this issue reproducable with the latest TYPO3 release and the latest release (2.5.6) of tx_srfeuserregister?

#6 Updated by Andreas Otto † almost 12 years ago

Fixed in SVN for trunk, 4.1 and 4.0 branches.

Also available in: Atom PDF