Bug #17174

W3C Warning: trimming empty <dd>

Added by Georg Ringer almost 14 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Content Rendering
Target version:
-
Start date:
2007-03-31
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If no caption is entered, then there is this ugly warning for every image (without caption) > <dd class="csc-textpic-caption"></dd>

To solve it:
tt_content.image.20.rendering.dl.caption.required=1

Can someon please check for 4.1 because I just have a 4.0.4 available

(issue imported from #M5331)


Files

0005331.patch (770 Bytes) 0005331.patch Administrator Admin, 2007-07-04 12:59

Related issues

Related to TYPO3 Core - Bug #17521: Typo3 v4.1.2 Image cObject does not render properly in IE7.0Closed2007-08-10

Actions
#1

Updated by Dominic Brander over 13 years ago

on 4.1.1 it works fine!
checked this on different installations.

#2

Updated by Georg Ringer over 13 years ago

thx.
and who will integrate this in the next version of css_styled_content?

#3

Updated by Dominic Brander over 13 years ago

I will ask Michael Stucki to do so.

#4

Updated by Oliver Hader over 13 years ago

I added a patch for this one as suggested in the initial bug description.
However, I could not reproduce the W3C warning using XHTML 1.0.
But generally it's good to remove unused/empty tags.

#5

Updated by Georg Ringer over 13 years ago

You should try with xhtml_11 (xhtml 1.1.) but I agree with removing unused tags - so thx a lot oliver

#6

Updated by Oliver Hader over 13 years ago

Committed to SVN:
  • TYPO3_4-1 (rev. 2395) -- will be part of TYPO3 4.1.2
  • Trunk (rev. 2396)

Also available in: Atom PDF