Bug #17373

TSFE : beUserLogin doesn't work, when config.baseUrl is set.

Added by Jan Wulff over 12 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2007-06-11
Due date:
% Done:

0%

TYPO3 Version:
4.1
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I'm using the value in "beUserLogin" from the TSFE, to check for an active backend user in one of my installations. The website uses a subdomain, so I set config.baseURL to the name of the subdomain. Once this is set, an active backend user isn't recognized any more in the frontend, as soon as he clicks on a link.

What I mean is, that the first frontend page (called from the backend with a click on a magnifier symbol) works as usual, but when the user navigates through the site, the field beUserLogin is 0 and all frontend editing symbols disappear.

This bug vanishes as soon as I clear config.baseURL.

(issue imported from #M5771)

History

#1 Updated by Chris topher about 11 years ago

I cannot reproduce this behaviour.

#2 Updated by Benni Mack almost 11 years ago

@Jan: Could you please give us some more details and tell us if the problem still occurs... otherwise we're gonna just close the bug.

#3 Updated by Martin Holtz over 10 years ago

i think the way to reproduce that is:

Login at:
www.example.com

if you a secound domain
www.subdomain.example.com
and you preview that page you will see that page, but if you click on any link, you are on domain "www.subdomain.example.com" but there you are not logged in. So
TSFE : beUserLogin will be zero - and that is correct (IMHO)

so, that is an multiple-domain issue - where you login to one domain, and you are not logged in at a second domain which is managed by the same typo3 installation

#4 Updated by Benni Mack over 10 years ago

OK. Additionally to Martins comment we got this:

+ this is a cookie issue as the session / cookie is bound to a domain
+ "if my cookie is bound to typo3.org - typo3.com should not get that cookie, so i cannot be logged in there" - makes sense, right?

Also available in: Atom PDF