Bug #17787

Use optgroups in selectorboxes

Added by Ingmar Schlecht over 13 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2007-11-14
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The page and content type selectors now group their options using --div-- dividers. TCEForm renders them as optically grouped bunches of options, but doesn't use the optgroup tag, which is meant for that.

The attached patch fixes this.

(issue imported from #M6710)


Files

optgroup-for-selectorboxes.patch (2.92 KB) optgroup-for-selectorboxes.patch Administrator Admin, 2007-11-14 13:37
6710_empty_optiongroups.diff (1.88 KB) 6710_empty_optiongroups.diff Administrator Admin, 2008-04-01 18:13
#1

Updated by Ingmar Schlecht over 13 years ago

Committed to trunk.

#2

Updated by Benni Mack about 13 years ago

Hey Ingmar,

the problem is that empty optgroups are still rendered and this is a serious issue with this one.

TCEFORM.tt_content.CType.removeItems = multimedia,bullets,table,script,upload,div,splash,uploads

does then show an empty optgroup entry, I think we should change this one. We should really fix this for 4.2 final, what do you think?

#3

Updated by Ingo Renner about 13 years ago

No, this is not necessary for 4.2 final.

#4

Updated by Ingo Renner about 13 years ago

... e.g. this will not block the release

#5

Updated by Steffen Kamper about 13 years ago

but patch is really simple, i attached it

#6

Updated by Ingo Renner about 13 years ago

committed the follow up patch

#7

Updated by Benni Mack about 13 years ago

switched target version from 4.2.1 to 4.2.0

Also available in: Atom PDF