Bug #17808

Ajax relogin won't relogin and ignores [BE][sessionTimeout]

Added by Jan Loderhose almost 12 years ago. Updated about 11 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2010-06-01
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.4
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Installed TYPO3 4.4.0beta3 this morning.
Set [BE][sessionTimeout] to 10 hours.

After some approx. 1,5 hours the ajax relogin dialog poped up, offering the possibility to log out or to stay logged in. Clicking on the stay logged in button resulted in a reload of the dialog and a refresh of the count down offering me another 30 secs to decide. This behavior remains reproducible. In contrast, logging out works reliably.

1. Set [BE][sessionTimeout] to an amount of some hours [36000 secs in my case]
2. Log into the backend (and do your admin/editors work)
3. Click on the stay logged in button when the dialog appears

TYPO3 4.4.0beta3
PHP 5.3.2
[BE][compressionLevel] = 5
FF 3.6.3
Windows Vista and 7
(issue imported from #M14580)


Related issues

Related to TYPO3 Core - Bug #17666: be sessions time out before $TYPO3_CONF_VARS["BE"]["sessionTimeout"]Closed2007-10-10

Actions
#1

Updated by Christian Nölle almost 12 years ago

Can reproduce this problem with the same setup, PHP Version can not be confirmed. Have to check that and will report.

#2

Updated by Jan Loderhose almost 12 years ago

Hurray, a typo ...

It hast to be TYPO3 4.4.0beta3 in description and additional information

#3

Updated by Chris topher almost 12 years ago

Since the problem occurs after 1- 2 hours the problem with [BE][sessionTimeout] seems to be the same as #17666. There the logout occured after 6000 seconds (round about 1 hour 40).

Can you check, if the problem is still the same (and maybe even provide a fix)?

#4

Updated by Jan Loderhose almost 12 years ago

Well, I must admit that I cannot reproduce the issue anymore ...

I reported this issue, after experiencing the described behavior throughout the day. Now everything works just as expected since I filed the bug. Mea culpa.

@Christian Noelle: How about your note?

#5

Updated by Jan Loderhose almost 12 years ago

Here we go again on TYPO3 4.4.0RC1 ...
[See Additional Information for the whole setup, replace TYPO3 version.]

I updated the website I first experienced this issue with to TYPO3 4.4.0RC1 this morning. Immediately the initially described behavior aroused again. (After everything went straight since Note 0038579.)

I searched the PHP error and transfer logs, fully enabled TYPO3 error/developer logs and tracked HTTP Headers with Live HTTP Headers on FF 3.6.3 for any hint on what could possibly go wrong. In vain ...

Can anybody (developer on the user validation preferably) provide some idea how to track down the right piece of information in any server or client log? Maybe I am just to blind or not deep enough into the validation process to get this bugger on my own ...

#6

Updated by Thomas Deinhamer almost 12 years ago

This happened to one of my workmates today which was working on a new TYPO3 4.4.0RC1 website, using Safari 5 on Mac OS X. Unfortunately it was working well on my PC, using Firefox 3.6.x on Windows Vista.

He was able to work in the backend as long as he wouldnt load or reload a frontend page. After that the backend session was gone and the ExtJS Popup came up.

When he immediately switched to the BE after a FE page was reloaded, he got a popup to enter the password and he was able to relogin. But when the session expired (this happened, when he reloaded a FE page and waited some minutes, before he switched to the BE browser tab) he would click the 'relogin' button of the popup a dozen times with no success. The pop was just reshowing again and again.

So, sorry for not beeing able to provide more information - it just happened on Safari 5 on Mac OS X.

#7

Updated by Jan Loderhose almost 12 years ago

Had a new experience today. Spices up some new flavor.

I played around with ext feeditadvanced last night. Time went by and the BE session timed out again. Without a relogin I was still authenticated in the FE.

I do not have ext simulatebe installed or in use. FE login system is not configured. I'm pretty sure that no third party extension (besides feeditadvanced possibly) has its hand in here, because no other is installed.

Maybe this gives some pointer to a hint at a possible cause.

#8

Updated by Jan Loderhose about 11 years ago

To my experience this issue those not occur any longer in current stable version.
What's your opinion? Close it?

#9

Updated by Christian Nölle about 11 years ago

Well, disappeared in my installations as well.

Also available in: Atom PDF