Bug #17828

RTEhtmlarea doesn't work with IRRE anymore

Added by Oliver Hader over 13 years ago. Updated almost 13 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2007-11-21
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In FF2, when having some IRRE elements, the error occours on opening them:
uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMNSHTMLDocument.queryCommandEnabled]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: http://www.fotobuch.de/typo3temp/rtehtmlarea/htmlarea_ed1449a90a31a33b666f.js :: anonymous :: line 227" data: no]

Works in IE7

(issue imported from #M6788)


Files

rtehtmlarea_bugfix_6788.patch (1.71 KB) rtehtmlarea_bugfix_6788.patch Administrator Admin, 2007-11-22 07:39

Related issues

Related to TYPO3 Core - Feature #17813: Enable htmlArea RTE in SafariClosedStanislas Rolland2007-11-19

Actions
#1

Updated by Stanislas Rolland over 13 years ago

Please try to delete all file in typo3temp with names starting with 'rtehtmlarea_'. Delete also typo3temp/rtehtmlarea directory.
Clear the browser cache.

#2

Updated by Stanislas Rolland over 13 years ago

Sorry, my error.

Fixed in SVN TYPO3core trunk, revision 2747.

Please confirm.

#3

Updated by Oliver Hader over 13 years ago

After removing the files in typo3temp/rtehtmlarea/ and clearing the browsers cache, this problem seems to be solved: +1

Thank you for the quick fix.

#4

Updated by Oliver Hader over 13 years ago

Committed to SVN Trunk -- will be in TYPO3 4.2-alpha3

#5

Updated by Oliver Hader over 13 years ago

Hm, seems like there's still a bug - I get the following with FF 2.0.0.11:
uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMNSHTMLDocument.queryCommandEnabled]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: http://irre.t3ip.de/typo3temp/rtehtmlarea/htmlarea_ed1449a90a31a33b666f.js :: anonymous :: line 1807" data: no]

This error occurs for every IRRE record that uses RTE.

#6

Updated by Oliver Hader over 13 years ago

The mentioned code in line 1807 was added in rev. 2735: Feature #6769: Enable htmlArea RTE in Safari

#7

Updated by Oliver Hader over 13 years ago

The error occurs only if the IRRE records are collapsed. You can compare this to a RTE field on a tab which is currently not active.

#8

Updated by Stanislas Rolland over 13 years ago

Yes. Will need to wrap the statement in a try & catch clause.

#9

Updated by Stanislas Rolland over 13 years ago

Fixed in trunk revision 2862

Also available in: Atom PDF