Bug #17870

Treatment of content-elements in front- and backend with language setting 'all'

Added by Karl Molter almost 12 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Content Rendering
Target version:
-
Start date:
2007-11-30
Due date:
% Done:

0%

TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Content elements with language setting [All] (sys_language_uid = -1) are not rendered in the frontend and are not shown in the backend Web->Page view.
This has been reported in several bulletin boards since about two years, but the problem still exists in version 4.1.3

To me it seems that the following modifications fixes the problem, but a core developer should have a look on it to decide wether it represents the philosophy of sys_language_uid = -1 correctly and if there are any other cases to be considered:

Frontend Fix:
file: typo3/sysext/cms/tslib/typo3/sysext/cms/tslib
line: 6697

modified from
$query.=' AND '.$conf['languageField'].' IN ('.$sys_language_content.')';
to
$query.=' AND '.$conf['languageField'].' IN ('.$sys_language_content.',-1)';

Backend Fix:
File: typo3/sysext/cms/layout/class.tx_cms_layout.php
Line: 419

Modified from
$showLanguage = $this->defLangBinding && $lP==0 ? ' AND sys_language_uid IN (0,-1)' : ' AND sys_language_uid='.$lP;
to
$showLanguage = $this->defLangBinding && $lP==0 ? ' AND sys_language_uid IN (0,-1)' : ' AND sys_language_uid IN ('.$lP.',-1)';

(issue imported from #M6867)

History

#1 Updated by Karl Molter almost 12 years ago

The path to the file to fix the problem in the frontend is:
typo3/sysext/cms/tslib/class.tslib_content.php

#2 Updated by Marc Neuhaus over 7 years ago

  • Target version deleted (0)

This is still an issue in 4.5.13.

#3 Updated by Wouter Wolters almost 5 years ago

  • Description updated (diff)
  • Status changed from New to Needs Feedback
  • TYPO3 Version set to 4.5
  • Is Regression set to No

Hi,

as this issue is very old. Does the problem still exists within newer versions of TYPO3 CMS (6.2.9)?

#4 Updated by Karl Molter over 4 years ago

Cannot reproduce it in TYPO3 6.2.9, looks fine there :-)

#5 Updated by Alexander Opitz over 4 years ago

  • Status changed from Needs Feedback to Closed

Thanks for feedback.

Also available in: Atom PDF