Bug #18008

Login has probably expired, when you create a new page (only in Safari and Internet Explorer)

Added by Stephan Laemmer over 13 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2008-01-17
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When you create a new page you will become the failure

Your login has probably expired.
Do you want to refresh it now?

When you press OK, it shows the popup-window with the logedin user. Not the form to log in, only the username. The page will not create in the page tree.
When you press Cancel, the page will create in the page tree.

In Firefox is the behaviour normal.

Safari 3.0.4 (5523.10.6), Mac OS X 10.5.1
PHP 5.2.4
MySQL 5.0.45

(issue imported from #M7184)


Files

0007184.patch (1.71 KB) 0007184.patch Administrator Admin, 2008-01-17 13:54

Related issues

Related to TYPO3 Core - Feature #17436: Notify user where required elements are nested in IRRE or TabsClosedOliver Hader2007-07-04

Actions
#1

Updated by Stephan Laemmer over 13 years ago

With Internet Explorer 7 (7.0.5730.11) I have the same problem as with Safari Browser.

#2

Updated by Oliver Hader over 13 years ago

I can confirm this for IE7.
TBE_EDITOR.loadTime is zero in this case and thus it looks for TBE_EDITOR like an outtimed session.

Looks like this call in t3lib_TCEforms is causing the error in IE7:

if (count($this->requiredNested)) {
    $out .= '
    TBE_EDITOR.addNested('.t3lib_div::array2json($this->requiredNested).');
    ';
}

#3

Updated by Oliver Hader over 13 years ago

In TBE_EDITOR the yellow images which indicate an unfilled required field are set by using the name attribute of HTML tags. However, RFC #17436 used an id for this on tabs.

#4

Updated by Stephan Laemmer over 13 years ago

Thank you, Oliver. Your patch is working great with Safari and Internet Explorer 7.

#5

Updated by Oliver Hader over 13 years ago

Committed to SVN Trunk (rev. 2921)

Also available in: Atom PDF