Feature #17436

Notify user where required elements are nested in IRRE or Tabs

Added by Oliver Hader over 12 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2007-07-04
Due date:
% Done:

0%

PHP Version:
4.3
Tags:
Complexity:
Sprint Focus:

Description

TYPO3 offers the possibility to define fields as "required". If done so, you cannot save a record unless all required fields are filled correctly.

Imagine you're using IRRE with Tabs and create a multilevel scenario with several required fields. If IRRE levels are collapsed or the tab with the required field is not visible - you'll spend some time on searching the field that has to be filled.

The feature request is to notify the user where these unfilled fields are.

Use the attached extension "test_required" to reproduce this behaviour and test further patches for this issue.

(issue imported from #M5899)

screenshot.png View (27 KB) Administrator Admin, 2007-07-04 17:31

0005899_v6.patch View (18.7 KB) Administrator Admin, 2007-07-14 15:59

0005899_v7.patch View (17.8 KB) Administrator Admin, 2008-01-15 11:46

T3X_test_required-0_0_0-z-200801151332.t3x (18.9 KB) Administrator Admin, 2008-01-15 13:36


Related issues

Related to TYPO3 Core - Bug #17448: RTEhtmlarea not correctly displayed in IRRE child form-fields and tabs (Part 2) Closed 2007-07-06
Related to TYPO3 Core - Bug #17468: TCA eval required on date field does not work Closed 2007-07-12
Related to TYPO3 Core - Feature #17900: Marking required fields in flexforms Rejected 2007-12-09
Related to TYPO3 Core - Bug #18008: Login has probably expired, when you create a new page (only in Safari and Internet Explorer) Closed 2008-01-17

History

#1 Updated by Oliver Hader over 12 years ago

The attached screenshot (screenshot.png) demonstrates some required fields nested in IRRE/Tabs. The yellow icons notify the user where to search and mark the path to those unfilled fields.

#2 Updated by Oliver Hader over 12 years ago

I've added a first approach on this issue (0005899_unstable.patch) which still has a bug on checking other element on the same level. Maybe the building of the lookup structure is also delegated to the Core in PHP in future.
But you can already test it and get notified if the are unfilled required fields.

#3 Updated by Oliver Hader over 12 years ago

I added a new patch (0005899.patch) that solves the nested level checks and handles the removal of sub structures.

Test it, taste it, enjoy it! ;-)

#4 Updated by Oliver Hader over 12 years ago

I adapted the patch to some changes concerning nesting in the TYPO3 Core.

#5 Updated by Steffen Kamper over 12 years ago

Wow !
Oliver, that's a great idea and excellent work !!!

thanks very much.

#6 Updated by Malte Jansen about 12 years ago

I used this patch and added an other feature.
Required-field should be conditional with checkbox-field.
See Bug: 0006173

But without this patch I had no clue how to start with my problem.
So thanks for this patch.

#7 Updated by Georg Ringer about 12 years ago

yeah works great
+100 for the next version

#8 Updated by Georg Ringer about 12 years ago

ok just discovered a small bug:
add an IRRE record which got a required field > the icon appears in the tab, at the irre record and of course inside the record at the field.

now i just delete the record again without opening it or editing it and the IRRE record of course disapears but the warning icon in the tab stays - saving now is still possible

#9 Updated by Georg Ringer almost 12 years ago

and i discovered a bigger bug: there is an JS error when creating a new parent record =>
line 465 (which is absolutly no JS code,..) -> document[..] is null or no object. There is also no icon shown in the tab and as soon as I click on save, a popup tells me that I am logged off. If i press cancel, the record is saved

testet with IE6 + 7.

this happens as soon as I enable this code

if (count($this->requiredNested)) {
$out .= '
TBE_EDITOR.addNested('.$this->inline->getJSON($this->requiredNested).');
';
};

so it is related to this patch. can anyone confirm this?

#10 Updated by Oliver Hader almost 12 years ago

This patch is pending in Core List since July 2007. But there have been other modifications to TYPO3, e.g. the "cleaner backend" and stuff like that. I know that this patch once worked.

I've spent much time in this patch and don't have the time to spend again this much time into it to make it working again with the Trunk. If nobody approves the patch in Core List, it's nonsense...

#11 Updated by Georg Ringer almost 12 years ago

i am working here with a 4.1.3 and not with a current trunk version. I guess just some lines are missing because it still works perfect with Firefox.

I still guess you just can commit features for IRRE by yourself because nobody knows it better than you and there are quite some very needed features out there for IRRE (like the translation patch of Bernhard) but I also totally understand you.

#12 Updated by Oliver Hader almost 12 years ago

Okay, maybe I have some time the next few days to get this work into the Core. And if you could test it, it would be enough - because it's true that nobody really understands, how IRRE works in detail. Thanks in advance!

#13 Updated by Georg Ringer almost 12 years ago

Sure I will. I got here quite a big project running with 12 tables and 8 of them in one IRRE with 5 Tabs, so this feature makes absolutly sense!

#14 Updated by Jeff Segars almost 12 years ago

Olly, does this patch work with individual flexform fields too or is it limited to IRRE records and tabs? Thanks!

#15 Updated by Oliver Hader almost 12 years ago

I attached a new changed version of the patch which now applies again correctly against the current Trunk. Please test and give me some feedback if you'd like to see this in the upcoming TYPO3 4.2.0-alpha3 release. Thanks in advance!

#16 Updated by Oliver Hader almost 12 years ago

Hi Georg, if you've got the time, could you please test the adjusted patch to get this hopfully into TYPO3 4.2.0-alpha3? Thanks in advance!

#17 Updated by Oliver Hader almost 12 years ago

Committed to SVN Trunk (rev. 2901)

Also available in: Atom PDF