Bug #18016

FCE-Dropdown shows Invalid Value Error when using comma

Added by Christopher Schnell almost 13 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2008-01-18
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.1
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When using an FCE-Dropdown list and there is a comma in the Dropdown value, it is not parsed correctly but an "Invalid Value" is shown instead. This happens when using CDATA, I have not tried it without (because I use also html (linebreak) there). This misbehaviour occurs both, when using the character "," as well as the encoding ","

The output is stopped at the character before the comma.

BTW. The TV Version is 1.3.3 but I cannot select it in the Product Version above.

This Bug was already reported in 2006 by Klaus Hinum on the TV Mailinglist, see http://lists.typo3.org/pipermail/typo3-project-templavoila/2006-May/000928.html

please find below the corresponding part of the XML

<field_aField type="array">
<tx_templavoila type="array">
<title>Test</title>
<eType>select</eType>
<tags>p</tags>
</tx_templavoila>
<TCEforms type="array">
<config type="array">
<type>select</type>
<items type="array">
<numIndex index="0" type="array">
<numIndex index="0"><![CDATA[A value without comma]]></numIndex>
<numIndex index="1"><![CDATA[Hello World]]></numIndex>
</numIndex>
<numIndex index="1" type="array">
<numIndex index="0"><![CDATA[A value with comma]]></numIndex>
<numIndex index="1"><![CDATA[Hello, World]]></numIndex>
</numIndex>
</items>
<default>0</default>
</config>
<label>The Test</label>
</TCEforms>
</field_aField>
(issue imported from #M7198)


Related issues

Related to TYPO3 Core - Bug #20021: Select doesn't allow comma in valueClosed2009-02-15

Actions
#1

Updated by Christopher Schnell almost 13 years ago

As a workaround, you can use the char "Single Low Quotation Mark" that looks pretty like a comma. the HTML-Encoding is "& sbquo;" (without the space between the "&" and the "s" of course).

#2

Updated by Tolleiv Nietsch almost 11 years ago

I'm sorry that's a TYPO3 Core issue with the TCEForm - I can confirm it for the latest TYPO3 trunk (4.4)

#3

Updated by Stig Kjeldsen almost 11 years ago

Is there any patch for the bug or is it possible to solve it somehow?

#4

Updated by Steffen Kamper almost 11 years ago

I already posted a patch for core, see #20021

#5

Updated by Alexander Opitz over 7 years ago

  • Status changed from Accepted to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#6

Updated by Alexander Opitz about 7 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback for over 90 days.

Also available in: Atom PDF