Bug #18074

Palette for 'Include static AFTER basedOn' seems to open wrongly.

Added by Kasper Ligaard almost 13 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2008-01-29
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.0
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

How to reproduce:
1) Choose Web>Template
2) Click on a page with a template
3) Click on 'Click here to edit whole template record'
4) Scroll to the bottom an make sure 'Show secondary options (palettes)' is turned off.
5) Click on the palette icons under:
a) 'Include static:'
b) 'Include static (from extensions):'
c) 'Include basis template:'

You will see that when clicking on the palette icon in b) and c) you close the palette opened when clicking a). In short: The palettes for a), b) and c) are the same palette - the same setting.

The reason this seems escp. weird in Typo3 4.2 is that palettes opens inline.

I think this should be changed, since the setting affects all three places.

Solution:
- Since the setting affects alle three places it should not be in a palette, it should be moved out to show that it affects all three places.

The attached patch solves this.

(issue imported from #M7312)


Files

fix-wrong-palettes.patch (999 Bytes) fix-wrong-palettes.patch Administrator Admin, 2008-01-29 12:09
#1

Updated by Kasper Ligaard almost 13 years ago

This has been fixed - probably when the restructuring into tabs happened. Anyways, this issue can be closed as 'fixed'.

#2

Updated by Oliver Hader over 12 years ago

Closed during Bug Day 07/2008

#3

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF