Bug #18116

Remove hardcoded references to alt_main.php backend interface

Added by Jeff Segars over 13 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2008-02-04
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Various places in the core are hardcoded to use the alt_main.php backend interface. I'm introducing a t3lib_BEfunc function to get the current backend script and use this instead of alt_main.php.

(issue imported from #M7386)


Files

20080204_remove_altmain.diff (3.87 KB) 20080204_remove_altmain.diff Administrator Admin, 2008-02-04 19:17

Related issues

Related to TYPO3 Core - Feature #17678: Change the frames BE to iframesClosedIngo Renner2007-10-14

Actions
Related to TYPO3 Core - Bug #18162: FE editing fails due to undefined methos in t3lib_BEfuncClosedJeff Segars2008-02-07

Actions
#1

Updated by Ingo Renner over 13 years ago

definitely a must have!

#2

Updated by Jeff Segars over 13 years ago

Committed to trunk in changeset 3069.

Also available in: Atom PDF