Bug #18312

Constants are not correctly substituted on some PHP5 distributions

Added by Oliver Hader over 11 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Communication
Target version:
-
Start date:
2008-02-26
Due date:
% Done:

0%

TYPO3 Version:
4.1
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

On some PHP5 distributions it happens that constants are not correctly substituted in t3lib_tstemplate. The reason is the the array pointer is not reset to the beginning after an array was created by using the explode() function.

(issue imported from #M7677)

0007677.patch View (825 Bytes) Administrator Admin, 2008-02-26 15:45


Related issues

Related to TYPO3 Core - Bug #18309: Change elderly while(list()=each()) to foreach calls in t3lib_tstemplate Closed 2008-02-26

History

#1 Updated by Oliver Hader over 11 years ago

The attached patch is for TYPO3 4.1.x only.

#2 Updated by Franz Holzinger over 11 years ago

The bug description is not correct. These codelines are not necessary for substituting the constants. They are only for a check if some constants found inside setup have not been substituted. These will be shown only if if ($this->tt_track) is set.
So IMHO this if should be moved some lines above before the whole block you have changed.
You will see that all variables changed in this blocked are not used outside.
IMHO this can go into 4.1 because it cannot do any harm if it does not change other variable contents. This is only used and needed for debugging.

#3 Updated by Benni Mack about 11 years ago

set version to 4.2.2 as maybe this one goes in the next bugfix version.

#4 Updated by Oliver Hader almost 11 years ago

Committed to SVN
  • TYPO3_4-1 (rev. 4742)
  • TYPO3_4-2 (rev. 4743)

Also available in: Atom PDF