Bug #18314

import extension page CSS errors

Added by Christoph Koehler over 11 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2008-02-26
Due date:
% Done:

0%

TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

There is overlapping content, see screenshot.

(issue imported from #M7682)

Picture 1.png View (30.6 KB) Administrator Admin, 2008-02-26 19:23

em-in-opera.png View (136 KB) Administrator Admin, 2008-03-03 17:53

opera_margins.jpg View (30.5 KB) Administrator Admin, 2008-03-03 19:15

7682_em_wrong_markup.diff View (1006 Bytes) Administrator Admin, 2008-03-03 19:38

7682_em_wrong_markup2.diff View (6.44 KB) Administrator Admin, 2008-03-04 12:07

7682_em_wrong_markup3.diff View (14.8 KB) Administrator Admin, 2008-03-04 13:52

7682_em_wrong_markup4.diff View (14.6 KB) Administrator Admin, 2008-03-06 23:12

7682_em_wrong_markup5.diff View (14.9 KB) Administrator Admin, 2008-03-07 13:49

try again.png View (15.7 KB) Administrator Admin, 2008-03-07 18:46


Related issues

Related to TYPO3 Core - Bug #18383: import/update extension causes js error Closed 2008-03-05

History

#1 Updated by Christoph Koehler over 11 years ago

Forgot to mention that this happens in Opera 9.26.

#2 Updated by Dmitry Dulepov over 11 years ago

This happens also when user installs extensions. See second screenshot (em-in-opera.png)

#3 Updated by Steffen Kamper over 11 years ago

I think that's all because the docheaders, Opera has problems with position absolute
Web>page: big margins at the bottom
Web>list: big margin on the top, big margins at the bottom
filelist: big margin at the top
etc.

#4 Updated by Christoph Koehler over 11 years ago

I don't see the big margins, sorry. It looks okay for me in Opera. The EM display errors are also much worse than anything in the file list or the web modules, so it can't (just) be the docheaders.
I may can take a look at it later.

#5 Updated by Steffen Kamper over 11 years ago

i attached a screen of the margins (Opera 9.26)

but you're right that EM is worse because it's unusable that way.

#6 Updated by Steffen Kamper over 11 years ago

I found the problem:
EM Module used nested forms, which is wrong and invalid markup.

Attached patch corrects this.

#7 Updated by Christoph Koehler over 11 years ago

tested and works.

#8 Updated by Steffen Kamper over 11 years ago

i attached a more complete patch with corrections in submodules of EM too.

#9 Updated by Steffen Kamper over 11 years ago

Once again i digged through whole code (over 5000 lines and many forms)

I corrected all forms now, please test again and check all functions.

#10 Updated by Christoph Koehler over 11 years ago

I guess this bug is related to that one: http://bugs.typo3.org/view.php?id=7771

#11 Updated by Steffen Kamper over 11 years ago

I found one new issue and fixed bug from #18383 too in
7682_em_wrong_markup4.diff

#12 Updated by Steffen Kamper over 11 years ago

and no. 5 which solves a new issue.

#13 Updated by Christoph Koehler over 11 years ago

attached try_again.png. The submit button there doesn't work either. You may have already fixed that, if so, ignore it.

#14 Updated by Christoph Koehler over 11 years ago

Applied your patch 5 and it does indeed fix that, so awesome, thanks!

Also available in: Atom PDF