Bug #18315

NOT NULL not recognized correctly on checking database fields

Added by Oliver Hader over 11 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Should have
Category:
Extension Manager
Target version:
-
Start date:
2008-02-26
Due date:
% Done:

0%

TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The defail view of an extension in the extension manager tells me that some database updates would be required - for e.g. tt_news I get the following:

ALTER TABLE tt_news CHANGE pid pid int(11) NOT NULL default '0';
Current value: int(11) DEFAULT '0'
ALTER TABLE tt_news CHANGE tstamp tstamp int(11) unsigned NOT NULL default '0';
Current value: int(11) unsigned DEFAULT '0'
ALTER TABLE tt_news CHANGE crdate crdate int(11) unsigned NOT NULL default '0';
Current value: int(11) unsigned DEFAULT '0'
... etc ...

The fields are correct in the database but however the check in the extension manager doesn't recognize the "NOT NULL" correctly.

(issue imported from #M7683)

not_null_em.png View (10.5 KB) Administrator Admin, 2008-02-26 22:27

rev3301_post1.diff View (623 Bytes) Administrator Admin, 2008-02-27 08:43

History

#1 Updated by Oliver Hader over 11 years ago

Caused by rev. 3301 in t3lib_install...
http://code.typo3.org/v4/changeset/3301

#3 Updated by Michael Stucki over 11 years ago

Sorry for this bugger! I changed the case type of all SQL statements including "default '...'" => DEFAULT '...', but it appears like TYPO3 depends on "DEFAULT" being lower-case.

I have reverted this part of the change, and everything runs fine again now.

- michael

Also available in: Atom PDF