Bug #18365

BE anusable if table sys_language is extended (MSSQL)

Added by Georg Ringer almost 13 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Database API (Doctrine DBAL)
Target version:
-
Start date:
2008-03-04
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.1
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If the table sys_language is extened by another field, it is not possible anymore to create pages/records in another language

it seems there is something hardcoded!

error msg from sqldebug
ERROR [Microsoft][ODBC SQL Server Driver][SQL Server]Die 'sys_language.langkey'-Spalte ist in der Auswahlliste ung�ltig, da sie nicht in einer Aggregatfunktion und nicht in der GROUP BY-Klausel enthalten ist.
--------- #
lastBuiltQuery SELECT "sys_language".* #
FROM "pages_language_overlay", "sys_language" #
WHERE #
"pages_language_overlay"."sys_language_uid" = "sys_language"."uid" AND "pages_language_overlay"."pid" = 23 #
GROUP BY "pages_language_overlay"."sys_language_uid", "sys_language"."uid", "sys_language"."pid", "sys_language"."tstamp", "sys_language"."hidden", "sys_language"."title", "sys_language"."static_lang_isocode", "sys_language"."flag" #
ORDER BY "sys_language"."title" #
debug_backtrace SC_alt_doc->main // SC_alt_doc->langSelector // SC_alt_doc->languageSwitch // SC_alt_doc->getLanguages // t3lib_DB->exec_SELECTgetRows // t3lib_DB->debug

(issue imported from #M7746)

#1

Updated by Alexander Opitz almost 8 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)
  • TYPO3 Version set to 4.1

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#2

Updated by Alexander Opitz over 7 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback for over 90 days.

Also available in: Atom PDF