Bug #18542

$TCA['tt_content']['interface']['maxSingleDBListItems'] =350

Added by Daniel Brüßler over 11 years ago. Updated 10 months ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2008-04-03
Due date:
% Done:

0%

TYPO3 Version:
4.1
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

in my 4.1.5 installation it doesn't like to work to set the max number for mod.web_list .

t3lib_div::loadTCA("tt_content");
$TCA['tt_content']['interface']['maxDBListItems'] = 30;
$TCA['tt_content']['interface']['maxSingleDBListItems'] = 500;

It just works with a hardcoded change:
var $itemsLimitSingleTable
in class.db_list.inc

(PHP 5.2.3)

=>
maybe also in 4.1.6 and 4.2, didn't test yet.

(issue imported from #M7993)


Related issues

Duplicates TYPO3 Core - Bug #20095: Listview: default limits are hardcoded Closed 2009-02-26

History

#1 Updated by Daniel Brüßler over 11 years ago

ben confirmed this as bug

+++
I needed this setting for the csv-export, because that just exports page1.

+++
Thanks for fixing it ;-)

#2 Updated by Daniel Brüßler over 11 years ago

Idea of Dmitry: page TSConfig (overridable by user TSConfig)

#3 Updated by Christian Kuhn over 10 years ago

Related to #19337

#4 Updated by Christian Kuhn over 10 years ago

Resolved as duplicate of #20095

#5 Updated by Benni Mack 10 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF