Bug #18646

Combination view not possible with symmetric relations

Added by Oliver Hader over 11 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2008-04-19
Due date:
% Done:

0%

TYPO3 Version:
4.1
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The combinations view, which allows one to edit a record directly which is again only related by an intermediate table, does not work.
Furthermore it a option for configuring a selector for the symmetric side is missing ("symmetric_selector") and endless recursions have to be checked in this context then.

(issue imported from #M8165)

0008165_unfinished.patch View (6.57 KB) Administrator Admin, 2008-04-19 20:54

0008165_unfinished_v3.patch View (15.5 KB) Administrator Admin, 2008-05-20 08:46


Related issues

Related to TYPO3 Core - Bug #17255: Combined mode doesn't work with type 'group' Closed 2007-04-27
Related to TYPO3 Core - Bug #18804: foreign_unique field not enough in symmetric relations Closed 2008-05-17

History

#1 Updated by Oliver Hader over 11 years ago

First version of the patch (unfinished) against TYPO3_4-2 branch:
  • reduced level of combination views to one (no combination-nesting allowed)
  • determine correct selector depending on the side from which a record is accessed in symmetric disposal
  • self-referencing records on deeper nested levels are shown virtually (they are shown but it's not possible that one can manipulate that record, because fields are already shown on upper levels)

Missing are the correct behaviours for selectors without combination on symmetric relationships.

#2 Updated by Alexander Opitz over 6 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#3 Updated by Alexander Opitz about 6 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback for over 90 days.

Also available in: Atom PDF