Bug #18654

Fatal error on calling sysLog() of lock object if locking method is unknown

Added by Oliver Hader about 13 years ago. Updated about 13 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Communication
Target version:
-
Start date:
2008-04-21
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If the front-end locking is set to an undefined method, e.g. "semaphoreVerySpecial", normally this should produce an entry in sysLog. But the $lockObj is not available since an exception was thrown there.

(issue imported from #M8182)


Files

0008182.patch (595 Bytes) 0008182.patch Administrator Admin, 2008-04-21 14:18

Related issues

Related to TYPO3 Core - Bug #18330: Fatal error if caching is disabled and locking enabledClosedOliver Hader2008-02-28

Actions
#1

Updated by Oliver Hader about 13 years ago

Committed to TYPO3_4-2 (rev. 3604)

Also available in: Atom PDF