Bug #18816

TYPO3_SITE_URL in t3lib_div::locationHeaderUrl to support TYPO3 installed in subfolders

Added by Christoph Koehler about 13 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2008-05-19
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Similar to bug #18803, REQUEST_HOST doesn't take subfolders into account, so we change it to TYPO3_SITE_URL instead.

(issue imported from #M8463)


Files

locationheader_siteurl.diff (591 Bytes) locationheader_siteurl.diff Administrator Admin, 2008-05-19 23:10

Related issues

Related to TYPO3 Core - Bug #18803: pageErrorHandling doesn't work with relative files in a subfolder TYPO3 installClosedPeter Niederlag2008-05-16

Actions
Related to TYPO3 Core - Bug #17878: mod_rewrite redirect to subdirectory + realurl = page not foundClosed2007-12-03

Actions
Related to TYPO3 Core - Bug #14856: TYPO3_SITE_URL is not set correctClosed2005-07-11

Actions
#1

Updated by Peter Niederlag about 11 years ago

Can you please give some information on how and where to reproduce the problem? Menu/function? Webserver/OS/PHP version? I have TYPO3 installed in a subfolder without problems for ages ....

#2

Updated by Christoph Koehler almost 11 years ago

Since the related bug 8441 worked, I'm sure this one is fine, too.

#3

Updated by Tolleiv Nietsch almost 10 years ago

  • Status changed from Needs Feedback to Closed
  • Target version deleted (0)

Also available in: Atom PDF