Bug #18867

Enhance page modul

Added by Steffen Kamper almost 12 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2008-05-28
Due date:
% Done:

0%

TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Description

there are several issues concerning the page module (classic)

  • CE's are not well separated
  • the view is crowded with ungrouped icons
  • there is too much info visible
  • edit links are not consistent, some texts are not linked
  • crop of text preview is hardcoded to 1500
  • Headers are not consistent with list view
  • CSH icon is at wrong position
  • CSH of big buttons has wrong position
  • quickedit has wrong order of funtion menus
  • not unique width of columns looks bad
  • difficult to get a visual focus, users are irretated

i tried to handle all issues in my patch, some screenshots are added

Beside the visual changes i did there are 3 new configuration params for usage in pageTS

var $showLanguageLabelInCE = false; // If set true, label for language will be shown in CE header
var $previewTextCropLength = 150; // sets length of preview text of CEs
var $columnWidth = 200; // fix width for columns

This has to be documented.

Usage (pageTS):

mod.web_layout { # this brings back the language labels in CE
showLanguageLabelInCE = 1 # sets preview text length
previewTextCropLength = 500 # sets fixed width for columns. For auto-width set it to 0
columnWidth = 280
}

(issue imported from #M8543)

new_web_layout1.png View (49.7 KB) Administrator Admin, 2008-05-28 20:37

new_web_layout2.png View (14.6 KB) Administrator Admin, 2008-05-28 20:38

new_web_layout3.png View (49.7 KB) Administrator Admin, 2008-05-28 20:38

web_layout.diff View (61.9 KB) Administrator Admin, 2008-05-28 22:39

typo3_8543.patch View (30.7 KB) Administrator Admin, 2008-11-11 14:39

8543_v3.patch View (30.8 KB) Administrator Admin, 2009-01-21 14:49

8543_4.3.1.patch View (30.9 KB) Administrator Admin, 2010-01-15 16:01


Related issues

Related to TYPO3 Core - Bug #17203: Access Check for Content Elements before drawing the Interface Closed 2007-04-12
Related to TYPO3 Core - Bug #22726: New Backend Design Closed 2010-05-27

History

#1 Updated by Ingo Renner almost 12 years ago

awesome!

#2 Updated by Stefan Galinski over 11 years ago

The last patch is against TYPO3 4.2.3. I hope there isn't anything missing in the patch, because it has only the half of the size from the original one. However the patch worked fine in my installation.

#3 Updated by Chris topher over 11 years ago

This is really a great patch! This really improves usability a lot!
I especially like the idea of the adjustable column-width.

One usability-improvement I miss in this module is, that the "Show secondary options" is always shown.

If there was a way to hide this checkbox, that would be great.
Could you still add that small feature?

This would make the patch perfect!

#4 Updated by Steffen Kamper over 11 years ago

Thanks to bring this up again, i will test your latest patch ASAP.

@Christopher - i know you want to hide the checkbox, but it's a different issue and should go to a different patch, as it belongs to different views.

#5 Updated by Stefan Galinski about 11 years ago

uploaded version 3 for TYPO3 4.2.4

#6 Updated by Ingo Renner about 11 years ago

why are you creating diffs against 4.2? We can't include it there anymore, just create patches against trunk, that'll do. =)

#7 Updated by Stefan Galinski over 9 years ago

The patch completely fails with 4.4, but IMHO it's not needed anymore in this version. Our skinning team did a great job!

#8 Updated by Ingo Renner over 9 years ago

agreed, the current version is even better

#9 Updated by Steffen Kamper over 9 years ago

solved in 4_4 with the new skin

#10 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF