Bug #18903

TYPO3Browser.js get not loaded

Added by Chi Hoang over 13 years ago. Updated almost 13 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2008-06-04
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In the default configuration Typo3 4.2 and rtehtmlarea 1.5.5, Javascript-File "TYPO3Browser.js" get not loaded. It has been created as compressed file in typo3temp, but it get not loaded.

(issue imported from #M8604)

#1

Updated by Oliver Hader over 13 years ago

rtehtmlarea 1.5.5 was part of TYPO3 4.1.4, but you're reporting this bug for TYPO3 4.2?!

#2

Updated by Chi Hoang over 13 years ago

Sorry. I mean of course Typo3 4.2 and rtehtmlarea 1.7.4.

#3

Updated by Chi Hoang over 13 years ago

Well, its seems to me that TYPO3Browser is deprecated. Especially I needed the JS-Function editor.renderPopup_addLink. This seems to be replaced by plugin.createLink. But I couldn't find any hint in the manual. :(. Issue can be closed. Thanks for your attention.

#4

Updated by Stanislas Rolland over 13 years ago

In TYPO3 4.2, all plugins except ContextMenu were restructured to use the new plugin API. Moreover, TYPO3Browser was replaced by two distinct plugins: TYPO3Image and TYPO3Link.

For documentation of the API, see http://typo3.org/documentation/document-library/extension-manuals/rtehtmlarea_api_manual/1.7.4/view/
However, detailed methods of each plugin are not currently defined as part of the API.

#5

Updated by Chi Hoang over 13 years ago

Sorry, for my question - but what is the difference between an extension and a plugin? I coulnd't figure out because you initialized extension in ext_localconf.php. Sadly the plugin TYPO3Browser.js is not defined as extension yet. So I wonder how can I include TYPO3Browser.js if I needed it!?

#6

Updated by Stanislas Rolland over 13 years ago

With TYPO3 4.2, you cannot because typo3browsers.js does not use the new API. It will be deleted in TYPO3 4.3.

An RTE extension is a php class that extends the rtehtmlarea TYPO3 extension. A plugin is a JS class that extends the htmlArea editor.

You should really read the htmlArea RTE API manual.

#7

Updated by Chi Hoang over 13 years ago

Sorry again for my misunderstanding. This must be my bad english knowledge, but why do each extension has a brother plugin?

#8

Updated by Stanislas Rolland over 13 years ago

You may think of the plugin as part of the extension.

However, plugins may exist without any extension. So are TYPO3Browsers and ContextMenu. But, TYPO3Browsers is not loaded in TYPO3 4.2.

#9

Updated by Chi Hoang over 13 years ago

So it is possible to initialized a plugin without haveing a brother extension? My problem was that I couldn't found that initialization routine. The manual teaches me that TYPO3Browsers.js is loaded. This causes me some headache. :)

#10

Updated by Stanislas Rolland over 13 years ago

I would think that there is an error in the manual. Please tell me where.

#11

Updated by Chi Hoang over 13 years ago

Page 21:

disableTYPO3Browsers | boolean | If set, the TYPO3 element browser is disabled in both the image and link dialogues. (Default: 0)

#12

Updated by Stanislas Rolland over 13 years ago

This does not refer to any plugin or to any javascript file. It just says that if the option is set the image and link insertion dialogues will be simplified and will not include any TYPO3 element browser.

I repeat: typo3browsers.js is not used in TYPO3 4.2 and will be deleted in TYPO3 4.3.

I think this should close this discussion as this bugtracker is not a support forum.

#13

Updated by Chi Hoang about 13 years ago

I do not understand.

#14

Updated by Stanislas Rolland about 13 years ago

You should look at plugin TYPO3Link which has replaced TYPO3Browsers plugin since TYPO3 4.2.0.

Also available in: Atom PDF