Bug #18989

Line break and Del key won't work correctly when when aligning the text as a block (justify)

Added by Klaus Hinum over 12 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Should have
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2008-06-19
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Using the "align justify" option in the RTE (e.g. button from demo mode), the text is correctly marked as p.align-justify. Afterwards, the Del key and the line break won't work any more (line break sometimes deletes spaces or won't break).

The text in the RTE is also not shown as justified (perhaps some CSS is missing, as the p.align-justify for the frontend had to be added manually in the css file).

(issue imported from #M8769)

#1

Updated by Klaus Hinum over 12 years ago

This happend since the update to Typo3 4.2 (new align justify method used in the RTE).

#2

Updated by Klaus Hinum over 12 years ago

I just noted, that it also happens sometimes (but less often) when the text is not justified.

#3

Updated by Susanne Moog over 12 years ago

I cannot reproduce this one. Tested with 4.2.0 and 4.2.1.

#4

Updated by Thomas Buss over 12 years ago

I can confirm this bug. Tested with 4.2.1, FF 2.0.0.16, Win2000

#5

Updated by Stanislas Rolland over 10 years ago

I am unable to reproduce this issue in TYPO3 4.3 or TYPO3 4.4 RC1.

Please explain exactly how to reproduce.

#6

Updated by Klaus Hinum over 10 years ago

Looks like it was fixed with Typo3 4.3 or so, but currently I have not stumbled across this error again.

#7

Updated by Stanislas Rolland over 9 years ago

  • Category set to RTE (rtehtmlarea + ckeditor)
  • Target version deleted (0)
  • TYPO3 Version set to 4.2
#8

Updated by Stanislas Rolland over 9 years ago

  • Status changed from New to Closed
  • Assignee set to Stanislas Rolland

Also available in: Atom PDF