Bug #19330

pages table cannot be used with t3lib_div::loadTCA

Added by Franz Holzinger over 11 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2008-09-15
Due date:
% Done:

0%

TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If you are programming a backend module, then you want to load the pages TCA using t3lib_div::loadTCA('pages'). Unfortunately this does not work, because the pages table does not have any $TCA['pages'][['ctrl']['dynamicConfigFile'] like all other tables have.

(issue imported from #M9348)

loadTCA-pages.diff View (8.01 KB) Administrator Admin, 2008-09-15 14:03


Related issues

Duplicates TYPO3 Core - Feature #23726: Refactor TCA definitions of table pages Closed 2010-10-14

History

#1 Updated by Alexander Opitz about 7 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#2 Updated by Franz Holzinger about 7 years ago

This has been fixed with TYPO3 6.0.
see file t3lib/stddb/tables.php

$TCA['pages'] = array(
    'ctrl' => array(
...
        'dynamicConfigFile' => 'T3LIB:tbl_pages.php',
...
    )
);

Close this issue.

#3 Updated by Alexander Opitz about 7 years ago

  • Status changed from Needs Feedback to Closed

Also available in: Atom PDF