Bug #19502

Multiple Fileupload into Folder with Umlauts not possible

Added by Christopher Schnell about 12 years ago. Updated almost 12 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2008-10-24
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When someone created a Folder like "testingÜmlauts" in the Filelist module and tries to upload multiple files, the action results in an error Message.

The displayed Error Message is "Parameter Error Target was not a directory!"

Regardless of whether someone should use or use not umlauts in fileadmin, this seems to be an error (at least the Message is wrong). This happens as well in TYPO3 4.1.x

(issue imported from #M9632)


Files

0009632.patch (1.22 KB) 0009632.patch Administrator Admin, 2008-10-29 00:54
0009632_rb41_v3.patch (2.68 KB) 0009632_rb41_v3.patch Administrator Admin, 2008-10-30 14:07
0009632_rb42_v3.patch (2.77 KB) 0009632_rb42_v3.patch Administrator Admin, 2008-10-30 14:07
0009632_trunk_v4.patch (3.53 KB) 0009632_trunk_v4.patch Administrator Admin, 2008-11-01 18:19
#1

Updated by Marcus Krause about 12 years ago

Used JS function escape() is known to be not able to handle unicode characters. Therefore escape() has to be replaced by encodeURIComponent() in the reload function.

@see:
http://itblog.cappuccinonet.com/2007/08/17/unterschiede-zwischen-javascript-escape-encodeuri-und-encodeuricomponent/
http://xkr.us/articles/javascript/encode-compare/

#2

Updated by Oliver Hader about 12 years ago

Committed to SVN:
  • TYPO3_4-1 (rev. 4406)
  • TYPO3_4-2 (rev. 4407)
  • Trunk (rev. 4408)

Also available in: Atom PDF