Bug #19559

AdminPanel shows superfluous "Include file class.tx_whatever_pi1.php" messages

Added by Oliver Hader almost 11 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2008-11-03
Due date:
% Done:

0%

TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The AdminPanel shows superfluous "Include file class.tx_whatever_pi1.php" messages even if the file was included before. That's not a real problem, since the file itself gets included by PHP's "include_once" and will be only loaded once. But the information in the AdminPanel can be improved.

For USER_INT objects the flow is like the following:
  • cObj: push object information to $GLOBALS['TSFE']->config['INTincScript'] (with includeLibs configuration)
  • TSFE: post-process objects and load files of includeLibs configuration
  • TSFE: recall cObj->USER as "USER" object (not "USER_INT") anymore
  • cObj: includeLibs is found again and information of "File inclusions" is shown

Solution:
a) remove includeLibs before passing again to cObj
b) track what files have been included before (but takes much longer)

(issue imported from #M9722)


Related issues

Related to TYPO3 Core - Feature #19510: Enable includeLibs also for USER and COA objects Closed 2008-10-27

History

#1 Updated by Alexander Opitz over 6 years ago

  • Status changed from Accepted to Needs Feedback
  • Target version deleted (-1)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#2 Updated by Alexander Opitz about 6 years ago

  • Status changed from Needs Feedback to Closed
  • Assignee deleted (Oliver Hader)
  • Is Regression set to No

No feedback for over 90 days.

Also available in: Atom PDF