Bug #19580

Some extensions do not work anymore in the frontend

Added by Oliver Hader about 11 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Communication
Target version:
-
Start date:
2008-11-06
Due date:
% Done:

0%

TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

[TYPO3 4.3-dev only]

Due to a change in #19510 the global includeLibs are not longer used by t3lib_extMgm - libraries are included only when they are required for rendering the specific data of an accordant plugin.

However, imagine the following situation:

plugin.tx_myext_pi1 = USER
plugin.tx_myext_pi1 {
includeLibs = EXT:myext/pi1/class.tx_myext_pi1.php
userFunc = tx_myext_pi1->main
}
page = PAGE
page.10 = USER
page.10.userFunc = tx_myext_pi1->renderHeader

This would result in an empty content of the tx_myext_pi1 plugin. Formerly the class "tx_myext_pi1" was loaded globally and available like this:
includeLibs.tx_myext_pi1 = EXT:myext/pi1/class.tx_myext_pi1.php

i.e. currently TemplaVoila won't render any content in the front-end - you get an empty page


The solution is to automatically search in the plugin structure for the "includeLibs" property and include the required files.

(issue imported from #M9748)

0009748.patch View (2.21 KB) Administrator Admin, 2008-11-06 15:34

0009748_v2.patch View (2.1 KB) Administrator Admin, 2008-11-12 13:10


Related issues

Related to TYPO3 Core - Feature #19510: Enable includeLibs also for USER and COA objects Closed 2008-10-27
Related to TYPO3 Core - Feature #19503: Implement autoloading for TYPO3 Closed 2008-10-24
Related to TYPO3 Core - Bug #19620: Frontend plugins show PHP error if there is no TypoScript configuration Closed 2008-11-17
Related to TYPO3 Core - Bug #20483: Misbehaviours due to integration of autoloader Closed 2009-05-20

History

#1 Updated by Ingo Renner about 11 years ago

I guess you can leave out the & here:
$pluginConfiguration =& $GLOBALS['TSFE']->tmpl->setup['plugin.'][$className . '.'];

#2 Updated by Steffen Kamper about 11 years ago

wouldn't this collidate with the autoloader? I think having the autoloader it's not needed.

#3 Updated by Oliver Hader almost 11 years ago

Committed to SVN Trunk (rev. 4458)

Also available in: Atom PDF