Bug #20483

Misbehaviours due to integration of autoloader

Added by Oliver Hader about 12 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2009-05-20
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The integration and activation of the autoloader created some misbehaviours:
  • DBAL seems not to be working anymore
  • TemplaVoila seems not to be working anymore

(issue imported from #M11156)


Files

0011156_dbal.patch (2.08 KB) 0011156_dbal.patch Administrator Admin, 2009-05-20 14:54
0011156_templavoila.patch (2.04 KB) 0011156_templavoila.patch Administrator Admin, 2009-05-20 14:54

Related issues

Related to TYPO3 Core - Feature #19503: Implement autoloading for TYPO3ClosedOliver Hader2008-10-24

Actions
Related to TYPO3 Core - Bug #19580: Some extensions do not work anymore in the frontendClosedOliver Hader2008-11-06

Actions
#1

Updated by Steffen Kamper about 12 years ago

The TV-issue has been solved by
includeLibs.tx_templavoila = EXT:templavoila/pi1/class.tx_templavoila_pi1.php

and is in svn of TV already

I tested successfully the XCLASS of t3lib_DB, and as it'S same for DBAL it should work (Xavier already mentioned that BE is fine, so DBAL was in action)

#2

Updated by Oliver Hader about 12 years ago

@Steffen: Was the requirement to use includeLibs for TemplaVoild introduced by the autoloader changes or was is there before?

#3

Updated by Oliver Hader about 12 years ago

Committed to SVN Trunk:
  • XCLASS/DBAL/AdoDB (rev. 5456)
  • includeLibs/TemplaVoila (rev. 5458)

Also available in: Atom PDF