Bug #19886

Not possible to set links to pages underneath a page with activated temporary DB mount

Added by Georg Ringer about 12 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2009-01-22
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
5.1
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I just discovered a serious bug in using the checkbox "Stop page tree" inside the page properties.

Imagine this tree
Page 1
Page 2 <=== Stop page Tree
Sub 1
Sub 2
Sub 2.1
Sub 2.2
Sub 3
Page 3

If i want to see the pages inside "Page 2", i need to click at the red + which will then show only the pages below this so called temporary DB mount.

The problem is that it is not possible to set links to pages below the "Page 2" because in the popup of RTE I still see the complete page tree (and not the smaller tree as in the 2nd frame) and if I click the red icon there, nothing happens!

IMO there are 2 solutions:
- If i am inside a temp. DB mount, this should also be the tree in the popup (with an option to delete the temp DB mount there)
- If the tree is created inside the popup, no temp DB mount should be set.

Of course solution #1 is nicer but I guess needs also more time.

I tested with 4.2.4 and trunk
(issue imported from #M10224)


Files

stoptree-10224.patch (3.09 KB) stoptree-10224.patch Administrator Admin, 2009-01-25 10:19
stoptree-10224-v2.patch (3.53 KB) stoptree-10224-v2.patch Administrator Admin, 2009-01-26 12:47
stoptree-10224-v3.patch (4.31 KB) stoptree-10224-v3.patch Administrator Admin, 2009-05-11 15:56
stoptree-10224-v3b.patch (4.21 KB) stoptree-10224-v3b.patch Administrator Admin, 2009-05-12 07:26
stoptree-10224-v3c.patch (7.04 KB) stoptree-10224-v3c.patch Administrator Admin, 2009-05-12 07:48
10224-temp-DB-mount-link-v4.patch (6.42 KB) 10224-temp-DB-mount-link-v4.patch Administrator Admin, 2010-02-26 16:20
#1

Updated by Georg Ringer about 12 years ago

v2 is a lot cleaner

#2

Updated by Georg Ringer almost 12 years ago

3b is latest version and also makes it possible to link to a page on other places like link of a header

#3

Updated by Susanne Moog almost 11 years ago

rev 7483

Also available in: Atom PDF