Bug #20027

Evaluation PATH_INFO in tslib_fe::checkAlternativeIdMethods() sets false positives and should be moved to tx_simulatestatic

Added by Oliver Hader over 12 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Communication
Target version:
-
Start date:
2009-02-16
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The method tslib_fe::checkAlternativeIdMethods() in TSFE tries to fetch the server environment PATH_INFO and if there's something it expects an URL like "/index.php/<page-id>/<type-number>/" and sets the current id and type accordant.

However, if config.simulateStaticDocuments is not set to "PATH_INFO" this is a false positive.

Since the functionality of simulateStaticDocuments was extracted to the system extension tx_simulatestatic in TYPO3 4.3, the mentioned part should also be moved to that place.

(issue imported from #M10452)


Files

0010452.patch (1.85 KB) 0010452.patch Administrator Admin, 2009-02-16 14:52
0010451_followup.patch (712 Bytes) 0010451_followup.patch Administrator Admin, 2009-02-20 16:18

Related issues

Related to TYPO3 Core - Bug #20026: Evaluation PATH_INFO in tslib_fe::checkAlternativeIdMethods() sets false positivesClosedOliver Hader2009-02-16

Actions
Related to TYPO3 Core - Feature #19178: Make simulate static a system extensionClosedBenni Mack2008-08-01

Actions
Related to TYPO3 Core - Bug #20062: Crash in the FE in 4.2.x branch (regression)ClosedOliver Hader2009-02-20

Actions
#1

Updated by Oliver Hader over 12 years ago

Additionally, the array value "html" was removed, since it is not used at all here...

#2

Updated by Oliver Hader over 12 years ago

Committed to Trunk (rev. 5031)

#3

Updated by Oliver Hader over 12 years ago

Committed follow-up to Trunk (rev. 5044)

Also available in: Atom PDF