Bug #20228

page cache never expire

Added by Bartosz Aninowski about 10 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2009-03-22
Due date:
% Done:

0%

TYPO3 Version:
4.3
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

1. set cache time in page properties to 1min
2. access page in frontend
3. check html source

<!-- Cached page generated 22-03-09 18:25. Expires 22-03-09 18:26 -->
<!-- Parsetime: 502 ms-->

4. wait 1min ore more
5. reload page, and check source

<!-- Cached page generated 22-03-09 18:25. Expires 22-03-09 18:26 -->
<!-- Parsetime: 512 ms-->

6. The same page version is returned.

Tested with file and db backend.

(issue imported from #M10763)

History

#1 Updated by Steffen Kamper about 10 years ago

did you use config.sendCacheHeaders = 1 ?

#2 Updated by Bartosz Aninowski about 10 years ago

no
config.sendCacheHeaders=0

#3 Updated by Alexander Opitz about 6 years ago

  • Category deleted (Communication)
  • Status changed from Accepted to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#4 Updated by Alexander Opitz over 5 years ago

  • Status changed from Needs Feedback to Closed
  • Assignee deleted (Rupert Germann)
  • Is Regression set to No

No feedback for over 90 days.

Also available in: Atom PDF