Bug #20594

FF: Cannot enable inline buttons when highlighting the first characters inside ul with list-style-position-inside

Added by Uschi Renziehausen over 12 years ago. Updated about 10 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2009-06-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hi Stan,

I detected a weird bug in FF3:

Problem:

Create a class for ul with the property list-style-positon: inside.
Create some li-elements and highlight the very first string of an li.
Result: The inline buttons remain disabled.

Now type a space before the first word and highlight it again (without the space). The inline buttons become active.

It is not that I think you can do anything about it (or can you), seems to be an FF thingy as I cannot reproduce this behaviour in Opera 9.63 and not in IE6.

Kind regards, Uschi

(issue imported from #M11298)

#1

Updated by Stanislas Rolland over 11 years ago

Hi Uschi,

My apologies for taking so long to reply to this issue.

I just tried to reproduce this issue with current trunk (revision 7843) and with Firefox 3.6.3. With no success.

If you start the selection before the first bullet, then the inline elements are disabled, but the status bar tells you that you are in fact selecting the whole ul. That is the only way I could reproduce a behaviour similar to your description.

Kind regards,
Stan

#2

Updated by Tolleiv Nietsch about 10 years ago

  • Status changed from Needs Feedback to Closed
  • Target version deleted (0)
  • TYPO3 Version set to 4.2

Closing this for the sake of a clean bugtracker - feel free to open it again once you're able to provide new input.

Also available in: Atom PDF