Bug #20722

Pagetree: Expand/collaps DB-Mounts buggy

Added by Uschi Renziehausen over 12 years ago. Updated about 11 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2009-07-06
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Problem:

User X has to DB-mounts

DBM 1
DBM 2

If he/she expands DBM 1 in the pagetree DBM 2 disappears completely. You can only get it back by reloading the tree.

(issue imported from #M11482)


Files

0011482_v1.diff (1.12 KB) 0011482_v1.diff Administrator Admin, 2009-07-31 18:46
#1

Updated by Nabil Saleh about 12 years ago

I tried to reproduce this error:

1st. created a testuser with a group that may see/edit all pages
2nd. added 2 small trees as dbmounts
3rd. su to the user in Firefox expand/reduce works fine on any mount
4th. logged in (not su) in IE8 => no problem either

am i missing something?

#2

Updated by Andreas Wolf about 12 years ago

This problem was introduced in revision 5342 - at least that's what a quick hunt with "git bisect" told me. I'll track it further down and provide a patch if possible

#3

Updated by Andreas Wolf about 12 years ago

I attached a patch for the issue. The problem was an unclosed div element with collapsed trees. This made at least Firefox get totally confused because of the messed up DOM structure.

The solution is quite simple: Always close the div element - which is used for styling tree elements - after the elements text. A subtree, if available, is now outside the div, directly underneath the ul - and besides the div.

#4

Updated by Andreas Wolf about 12 years ago

The patch has one small flaw when applied with some patch tools. They don't seem to like the second line, which was added by git. In that case, just remove this line.

#5

Updated by Steffen Kamper about 12 years ago

committed to trunk, rev 5859

Also available in: Atom PDF